Forums | Back to Concur Developer Center

500 Error when creating vendors through API


#1

I am able to GET vendors back at the endpoint /api/v3.0/invoice/vendors
But when I try to POST to /api/v3.0/invoice/vendors I get:
{"Error":{"Message":"Unexpected error.Please contact Developer Support"... in response.

Obviously, that error message is not very informative. So I have been trying to figure out what is going on. And looks like it is an issue on Concur’s side. But I thought that maybe someone else would see something on my end that I am missing.

I am posting
{"Vendor":[{"VendorCode":"C10001","VendorName":"Amazon CA","AddressCode":"C10001"}]}

I am including all of the required fields. So I don’t see what could be wrong.

Thanks!
Tim


#2

Hi Tim,

I believe there are few more required fields.
Following is the bare minimum info I had to provide to get the Vendor Post.

Vendor Code
Vendor Name
Address Code
Address 1
City
State
Postal Code
Country Code
Currency Code

Hope this helps.
Ravi @Metrie.


#3

Hi Ravi,

I tried adding those additional fields:

{

“Vendor”:

[

{

“City”:“Austin”,

“State”:“TX”,

“Address1”:“123 Vendor Home”,

“PostalCode”:“78653”,

“VendorCode”:“A12345”,

“VendorName”:“TestVendor”,

“AddressCode”:“A12345”,

“CountryCode”:“US”,

“CurrencyCode”:“USD”

}

]

}

But still get the same error:

{"Error":{"Message":"Unexpected error.Please contact Developer Support","Server-Time":"2018-09-14T14:48:26","Id":"D335EA44-D4C2-4E42-8E0D-DC73FF717B8F"}}

Do you see any error in the data I am posting?

Is it possible that there is some permission error or miss configuration to the concur account we are connected to?

I believe this was working fine a few weeks ago. I’m not sure what could have changed.

Thanks,

Tim


#4

Hi Tim,

Don’t see any issues with your data. Was able to post it on our test with that. Attaching screen shot.

Couple of things I would suggest is to try using PUT instead of POST.
Also, not sure if this matters, but the data you sent is enclosed in angular double quotes. I have to replace/retype with double quotes. Could be picky at times.

Good luck.

Ravi.


#5

We also started seeing this same problem on 9/8 with no changes to our code. We are able to make other API calls with no problems. Did you figure out what the issue was?


#6

We still haven’t been able to figure it out.
I even am getting the error when making test posts via their Api-Explorer https://developer.concur.com/api-explorer/v3-0/Vendors.html

I was, however, able to get in contact with a technician on concur’s side that is able to reproduce the error and is looking into the issue. Hoping to have a solution soon!


#7

Glad you were able to reproduce it! This is definitely causing us problems. I hope they figure it out soon.


#8

Any word on this? We are still seeing the problem. :frowning:


#9

I did get a response over the weekend saying that they found and resolved the issue.
They didn’t give me any insight into what went wrong though. But I am now able to make posts/updates to vendors.
I had assumed that if they fixed it for me then it would be fixed for everyone. It may be a case by case issue or unrelated. I’m not sure.


#10

We did finally get a fix for this with no change to our code.